Issue:
All Service Now Target migrations are failing with the error below:
ERROR: Unrecognised Response from Import Set Migration [{sys-id}]
Cause:
The cause of this issue is usually that the target ServiceNow instance is processing Import Sets asynchronously. By default, Service Now is configured to process synchronously. This allows the Transform map processing to return results to Precision Bridge on the success or failure of each migrated record. However if asynchronous processing is enabled, the record may, have migrated successfully, but Precision Bridge does not get any synchronous response on completion of processing and will report this error.
Resolution:
A business rule, running on the sys_import_set table, named Insert multiple asynchronous mode controls asynchronous processing of import sets. This is disabled by default. If it is enabled, the error above will occur.
Either disable this business rule, or change its condition in such a way that it will run during Precision Bridge migrations, perhaps by excluding the user that is defined in the target connection for the PB migration in its condition (see example below)

In addition to changing this business rule, delete any existing import set records where mode = asynchronous. This will prevent Precision Bridge adding import set rows to an existing import set that is operating asynchronously.
Comments
0 comments
Please sign in to leave a comment.